summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-10 08:04:40 +0100
committerSam James <sam@gentoo.org>2024-07-10 08:04:59 +0100
commitf46038204a524c907de3ebc16037f415117b8f25 (patch)
tree84b7a4cc535799d4b84768ef142173fcf2a05521 /dev-python
parentdev-vcs/repo: add 2.46 (diff)
downloadgentoo-f46038204a524c907de3ebc16037f415117b8f25.tar.gz
gentoo-f46038204a524c907de3ebc16037f415117b8f25.tar.bz2
gentoo-f46038204a524c907de3ebc16037f415117b8f25.zip
dev-python/mypy: fix disabling mypyc for py3.13
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mypy/mypy-1.10.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/mypy/mypy-1.10.1.ebuild b/dev-python/mypy/mypy-1.10.1.ebuild
index b87fe789fc41..9bd317074557 100644
--- a/dev-python/mypy/mypy-1.10.1.ebuild
+++ b/dev-python/mypy/mypy-1.10.1.ebuild
@@ -63,14 +63,15 @@ PATCHES=(
# test files (https://github.com/mypyc/mypyc/issues/1014)
export CCACHE_DISABLE=1
-src_compile() {
+python_compile() {
local -x MYPY_USE_MYPYC=$(usex native-extensions 1 0)
case ${EPYTHON} in
python3.13)
# https://github.com/mypyc/mypyc/issues/1056
MYPY_USE_MYPYC=0
+ ;;
esac
- distutils-r1_src_compile
+ distutils-r1_python_compile
}
python_test() {