summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-06-20 19:09:01 +0200
committerGuilherme Amadio <amadio@gentoo.org>2020-06-20 19:28:59 +0200
commitf0034e50a8356e79a06eacf871e952e818a8634f (patch)
treee2eeb5218d77c646d72ac3de107b24fdfb70be81 /dev-util/uftrace
parentdev-util/uftrace: add myself as maintainer (diff)
downloadgentoo-f0034e50a8356e79a06eacf871e952e818a8634f.tar.gz
gentoo-f0034e50a8356e79a06eacf871e952e818a8634f.tar.bz2
gentoo-f0034e50a8356e79a06eacf871e952e818a8634f.zip
dev-util/uftrace: remove support for python2.7
Also, fix support for bash-completion and add USE=luajit. Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-util/uftrace')
-rw-r--r--dev-util/uftrace/uftrace-0.9.3.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/dev-util/uftrace/uftrace-0.9.3.ebuild b/dev-util/uftrace/uftrace-0.9.3.ebuild
index d48d238c8012..51506dbff692 100644
--- a/dev-util/uftrace/uftrace-0.9.3.ebuild
+++ b/dev-util/uftrace/uftrace-0.9.3.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
+inherit bash-completion-r1
DESCRIPTION="Function (graph) tracer for user-space"
HOMEPAGE="https://github.com/namhyung/uftrace"
@@ -14,25 +12,32 @@ SRC_URI="https://github.com/namhyung/uftrace/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="capstone"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
+IUSE="bash-completion capstone luajit"
RESTRICT="test"
RDEPEND="
- ${PYTHON_DEPS}
- sys-devel/gcc:*[cxx]
sys-libs/ncurses:=
virtual/libelf:=
capstone? ( dev-libs/capstone:0= )
+ luajit? ( dev-lang/luajit )
"
DEPEND="${RDEPEND}"
src_prepare() {
default
- sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" Makefile || die
+ sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" -e "/bash.completion/d" Makefile || die
}
src_configure() {
- econf $(use_with capstone)
+ econf \
+ $(use_with capstone) \
+ $(use_with luajit libluajit) \
+ --without-libpython
+}
+
+src_install() {
+ default
+ dodoc doc/*.{md,gif,png}
+ use bash-completion && newbashcomp misc/bash-completion.sh uftrace
}