summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-03-21 20:13:08 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-21 20:13:08 +0100
commit49f82205aa01627c9b8941f95c24c42b7a8adc45 (patch)
treef247f60c1d26403471a88a8605e7c139c21a9dc6 /gui-libs
parentmedia-fonts/Humor-Sans: EAPI-7 bump, fix DESCRIPTION typo (diff)
downloadgentoo-49f82205aa01627c9b8941f95c24c42b7a8adc45.tar.gz
gentoo-49f82205aa01627c9b8941f95c24c42b7a8adc45.tar.bz2
gentoo-49f82205aa01627c9b8941f95c24c42b7a8adc45.zip
gui-libs/egl-wayland: allow building without xlib headers
Closes: https://github.com/gentoo/gentoo/pull/20043 Closes: https://bugs.gentoo.org/777558 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
index c853264cb3dd..931329d094c9 100644
--- a/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson
+inherit flag-o-matic meson
DESCRIPTION="EGLStream-based Wayland external platform (for NVIDIA)"
HOMEPAGE="https://github.com/NVIDIA/egl-wayland"
@@ -26,6 +26,13 @@ PATCHES=(
"${FILESDIR}"/${P}-remove-werror.patch
)
+src_configure() {
+ # EGLStream is not intended for X11, always build without (bug #777558)
+ append-cppflags -DEGL_NO_X11
+
+ meson_src_configure
+}
+
src_install() {
meson_src_install