summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/gr-iqbal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/gr-iqbal')
-rw-r--r--net-wireless/gr-iqbal/Manifest2
-rw-r--r--net-wireless/gr-iqbal/files/add-pkgconfig-file.patch52
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.36.0.ebuild39
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild32
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-9999.ebuild32
-rw-r--r--net-wireless/gr-iqbal/metadata.xml12
6 files changed, 169 insertions, 0 deletions
diff --git a/net-wireless/gr-iqbal/Manifest b/net-wireless/gr-iqbal/Manifest
new file mode 100644
index 000000000000..7172b06c7119
--- /dev/null
+++ b/net-wireless/gr-iqbal/Manifest
@@ -0,0 +1,2 @@
+DIST gr-iqbal-0.36.0.tar.xz 76504 SHA256 7715142d5fd478ade7536f015f6764a6a0c113c931b381e4536d1c681ad778d6 SHA512 1fd91f5ea2984e71826906437bb32b3518191e69411d74ecfcdd09b18b545c4b42d097366dae0d430f75e9c5dd72c7c0425cd1de3551c2a9eacae983f87d4204 WHIRLPOOL db5c54f226682aea33eb61952d1e2cea8be6c343c59d356539ed7f0379767a732bbca4d889f5caa320a4941a52589cef1101add34879fa9304b983e2f6e42e15
+DIST gr-iqbal-0.37.2.tar.xz 71340 SHA256 7b15b404634cf91209ff0e17350f87307ab88ab6b795f7d5a60ed009f5492824 SHA512 00037a535219ebe3b5244d4a09355cc74bf17aa6a935bff135e9d7c7c7f6bc1c8b7a29edc02132dbacda2c41efa3613c09e6fdc222472e58d88c4c076736842e WHIRLPOOL 2afdf6bc97d07d2aaf888336987c9f437b76a0216cef904d7319d98ce914565c28ced0c9397e35da1fcc65aabc852a81e8df3a81441fe0800ed03e65cd5ff125
diff --git a/net-wireless/gr-iqbal/files/add-pkgconfig-file.patch b/net-wireless/gr-iqbal/files/add-pkgconfig-file.patch
new file mode 100644
index 000000000000..c86cdfa458c2
--- /dev/null
+++ b/net-wireless/gr-iqbal/files/add-pkgconfig-file.patch
@@ -0,0 +1,52 @@
+From 077397e65a8867fe3e93de0930d9556d39f10126 Mon Sep 17 00:00:00 2001
+From: Sylvain Munaut <tnt@246tNt.com>
+Date: Sun, 07 Jul 2013 19:54:23 +0000
+Subject: misc: Add a .pc file
+
+Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
+---
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a251954..10dc8c8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -158,3 +158,21 @@ add_subdirectory(python)
+ add_subdirectory(grc)
+ add_subdirectory(apps)
+ add_subdirectory(docs)
++
++########################################################################
++# Create Pkg Config File
++########################################################################
++file(TO_NATIVE_PATH "${CMAKE_INSTALL_PREFIX}" prefix)
++file(TO_NATIVE_PATH "\${prefix}" exec_prefix)
++file(TO_NATIVE_PATH "\${exec_prefix}/${GR_LIBRARY_DIR}" libdir)
++file(TO_NATIVE_PATH "\${prefix}/${GR_INCLUDE_DIR}" includedir)
++
++configure_file(
++ ${CMAKE_CURRENT_SOURCE_DIR}/gnuradio-iqbalance.pc.in
++ ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-iqbalance.pc
++@ONLY)
++
++install(
++ FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-iqbalance.pc
++ DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
++)
+diff --git a/gnuradio-iqbalance.pc.in b/gnuradio-iqbalance.pc.in
+new file mode 100644
+index 0000000..edde90d
+--- /dev/null
++++ b/gnuradio-iqbalance.pc.in
+@@ -0,0 +1,11 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: gnuradio-iqbalance
++Description: gnuradio I/Q balancing
++URL: http://git.osmocom.org/gr-iqbal/
++Requires: gnuradio-runtime
++Libs: -L${libdir} -lgnuradio-iqbalance
++Cflags: -I${includedir}
+--
+cgit v0.9.1
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.36.0.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.36.0.ebuild
new file mode 100644
index 000000000000..c6033fd9cd9a
--- /dev/null
+++ b/net-wireless/gr-iqbal/gr-iqbal-0.36.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_DEPEND="2"
+
+inherit cmake-utils python
+
+DESCRIPTION="gnuradio I/Q balancing"
+HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="<net-wireless/gnuradio-3.7_rc:0=
+ net-libs/libosmo-dsp:=
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -q -r 2 "${S}"
+}
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild
new file mode 100644
index 000000000000..73f518523423
--- /dev/null
+++ b/net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="gnuradio I/Q balancing"
+HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
+ net-libs/libosmo-dsp:=
+ dev-libs/boost:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild b/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild
new file mode 100644
index 000000000000..73f518523423
--- /dev/null
+++ b/net-wireless/gr-iqbal/gr-iqbal-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="gnuradio I/Q balancing"
+HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
+ net-libs/libosmo-dsp:=
+ dev-libs/boost:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/net-wireless/gr-iqbal/metadata.xml b/net-wireless/gr-iqbal/metadata.xml
new file mode 100644
index 000000000000..044f12194316
--- /dev/null
+++ b/net-wireless/gr-iqbal/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<herd>radio</herd>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+