summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/godot')
-rw-r--r--dev-games/godot/Manifest2
-rw-r--r--dev-games/godot/files/godot-3.5-musl.patch9
-rw-r--r--dev-games/godot/files/godot-3.5-scons.patch74
-rw-r--r--dev-games/godot/files/godot-3.5.3-gcc13.patch9
-rw-r--r--dev-games/godot/files/godot-4.0_rc2-musl.patch21
-rw-r--r--dev-games/godot/files/godot-4.0_rc3-scons.patch15
-rw-r--r--dev-games/godot/godot-3.5.3-r1.ebuild218
-rw-r--r--dev-games/godot/godot-4.2.2-r1.ebuild238
-rw-r--r--dev-games/godot/metadata.xml2
9 files changed, 0 insertions, 588 deletions
diff --git a/dev-games/godot/Manifest b/dev-games/godot/Manifest
index 8d87ae02a38c..5a5473e4a4b7 100644
--- a/dev-games/godot/Manifest
+++ b/dev-games/godot/Manifest
@@ -1,3 +1 @@
-DIST godot-3.5.3-stable.tar.xz 24072964 BLAKE2B a4c03328e3aa77d741a1c642cfd645de04084f2852e865757fc8960c4919d3b8b8571e772f44004901fdd80a967e8e21bd8c6be8b36263db7afae787dcbd3ed6 SHA512 4c008af5bb7c298d465edbe03f6ebc642f5bbbb0a4254e99d7a7a88919e1f9424b98c5dff95a55ae68d4e2e5878c7c0bb7d13a66869cb632ecb51a913f865155
-DIST godot-4.2.2-stable.tar.xz 26768552 BLAKE2B e4a6040d7a1f63f841f56d74bb7b04e58f2fa26ddd8850df7f93937deb10c4af925ea2059c174d9f457222e0cddfe477498e3462bfaaf69ec8e57de8f2d43c83 SHA512 4a623063be5488957e1ede7e45b6865f6cd61bc954ac311587b9e97bed848a4083c4a7225d0a81bca285d854d33be9b07d7d0c21465c9f25b90e92b08090429c
DIST godot-4.3-stable.tar.xz 29140004 BLAKE2B 0698cf6c8ba853d094c39b461efe998c57a7de0609701e46cca48b17c29eca3da29c8644aa356cff330d1d3ae88048afc2148f5389d57cdfa1dd26784e6d9a44 SHA512 6e1eaba5c3447527ce60d623f7f81cbd90633a5a1ad4c6dd469055a43c8fb9b4807fcd3bae25331294596c2418eb6c0c9db0871c3e1405ddcc7d84e29c39a45b
diff --git a/dev-games/godot/files/godot-3.5-musl.patch b/dev-games/godot/files/godot-3.5-musl.patch
deleted file mode 100644
index 0738b035480f..000000000000
--- a/dev-games/godot/files/godot-3.5-musl.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-crash handler requires glibc or libexecinfo (not packaged),
-and is always enabled if build the editor (release_debug)
---- a/platform/x11/crash_handler_x11.cpp
-+++ b/platform/x11/crash_handler_x11.cpp
-@@ -38,3 +38,3 @@
-
--#ifdef DEBUG_ENABLED
-+#if defined(DEBUG_ENABLED) && defined(__GLIBC__)
- #define CRASH_HANDLER_ENABLED 1
diff --git a/dev-games/godot/files/godot-3.5-scons.patch b/dev-games/godot/files/godot-3.5-scons.patch
deleted file mode 100644
index b8ed7f50311d..000000000000
--- a/dev-games/godot/files/godot-3.5-scons.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-* add option to respect AR
- (respecting PKG_CONFIG is handled in the ebuild)
-* handle recastnavigation unbundling
-* remove unnecessary opusfile
-* remove unnecessary -no-pie
-* remove -pipe from LDFLAGS, may "possibly" be relevant to:
- https://bugs.gentoo.org/861689
- https://github.com/godotengine/godot/commit/f035e784
---- a/SConstruct
-+++ b/SConstruct
-@@ -192,4 +192,5 @@
- opts.Add("CXX", "C++ compiler")
- opts.Add("CC", "C compiler")
-+opts.Add("AR", "Archiver")
- opts.Add("LINK", "Linker")
- opts.Add("CCFLAGS", "Custom flags for both the C and C++ compilers")
---- a/platform/server/detect.py
-+++ b/platform/server/detect.py
-@@ -135,5 +135,4 @@
-
- env.Append(CCFLAGS=["-pipe"])
-- env.Append(LINKFLAGS=["-pipe"])
-
- ## Dependencies
-@@ -178,4 +177,7 @@
- env.ParseConfig("pkg-config libenet --cflags --libs")
-
-+ if not env["builtin_recast"]:
-+ env.ParseConfig("pkg-config recastnavigation --cflags --libs")
-+
- if not env["builtin_squish"]:
- env.ParseConfig("pkg-config libsquish --cflags --libs")
-@@ -205,5 +207,5 @@
- if not env["builtin_opus"]:
- env["builtin_libogg"] = False # Needed to link against system opus
-- env.ParseConfig("pkg-config opus opusfile --cflags --libs")
-+ env.ParseConfig("pkg-config opus --cflags --libs")
-
- if not env["builtin_libogg"]:
---- a/platform/x11/detect.py
-+++ b/platform/x11/detect.py
-@@ -232,17 +232,5 @@
-
- env.Append(CCFLAGS=["-pipe"])
-- env.Append(LINKFLAGS=["-pipe"])
-
-- # Check for gcc version >= 6 before adding -no-pie
-- version = get_compiler_version(env) or [-1, -1]
-- if using_gcc(env):
-- if version[0] >= 6:
-- env.Append(CCFLAGS=["-fpie"])
-- env.Append(LINKFLAGS=["-no-pie"])
-- # Do the same for clang should be fine with Clang 4 and higher
-- if using_clang(env):
-- if version[0] >= 4:
-- env.Append(CCFLAGS=["-fpie"])
-- env.Append(LINKFLAGS=["-no-pie"])
-
- ## Dependencies
-@@ -298,4 +286,7 @@
- env.ParseConfig("pkg-config libenet --cflags --libs")
-
-+ if not env["builtin_recast"]:
-+ env.ParseConfig("pkg-config recastnavigation --cflags --libs")
-+
- if not env["builtin_squish"]:
- env.ParseConfig("pkg-config libsquish --cflags --libs")
-@@ -325,5 +316,5 @@
- if not env["builtin_opus"]:
- env["builtin_libogg"] = False # Needed to link against system opus
-- env.ParseConfig("pkg-config opus opusfile --cflags --libs")
-+ env.ParseConfig("pkg-config opus --cflags --libs")
-
- if not env["builtin_libogg"]:
diff --git a/dev-games/godot/files/godot-3.5.3-gcc13.patch b/dev-games/godot/files/godot-3.5.3-gcc13.patch
deleted file mode 100644
index dd681b87dce5..000000000000
--- a/dev-games/godot/files/godot-3.5.3-gcc13.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-Issues seem(?) to only trigger when gcc13 is combined with musl.
-
-https://bugs.gentoo.org/906363
---- a/modules/fbx/fbx_parser/FBXCommon.h
-+++ b/modules/fbx/fbx_parser/FBXCommon.h
-@@ -78,2 +78,3 @@
-
-+#include <cstdint>
- #include <string>
diff --git a/dev-games/godot/files/godot-4.0_rc2-musl.patch b/dev-games/godot/files/godot-4.0_rc2-musl.patch
deleted file mode 100644
index 3b9a458ac7d4..000000000000
--- a/dev-games/godot/files/godot-4.0_rc2-musl.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Crash handler requires glibc or libexecinfo (not packaged) and is enabled
-if build the editor (implies debug), but can be easily turned off.
-https://bugs.gentoo.org/894762
---- a/platform/linuxbsd/crash_handler_linuxbsd.cpp
-+++ b/platform/linuxbsd/crash_handler_linuxbsd.cpp
-@@ -38,3 +38,3 @@
-
--#ifdef DEBUG_ENABLED
-+#if defined(DEBUG_ENABLED) && defined(__GLIBC__)
- #define CRASH_HANDLER_ENABLED 1
---- a/platform/linuxbsd/detect.py
-+++ b/platform/linuxbsd/detect.py
-@@ -329,8 +329,2 @@
-
-- if not env["execinfo"] and platform.libc_ver()[0] != "glibc":
-- # The default crash handler depends on glibc, so if the host uses
-- # a different libc (BSD libc, musl), fall back to libexecinfo.
-- print("Note: Using `execinfo=yes` for the crash handler as required on platforms where glibc is missing.")
-- env["execinfo"] = True
--
- if env["execinfo"]:
diff --git a/dev-games/godot/files/godot-4.0_rc3-scons.patch b/dev-games/godot/files/godot-4.0_rc3-scons.patch
deleted file mode 100644
index 682e1510ac94..000000000000
--- a/dev-games/godot/files/godot-4.0_rc3-scons.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/SConstruct
-+++ b/SConstruct
-@@ -241,2 +241,3 @@
- opts.Add("CC", "C compiler")
-+opts.Add("AR", "Archiver")
- opts.Add("LINK", "Linker")
-@@ -569,8 +570,2 @@
- env.Append(CCFLAGS=["-g2"])
-- else:
-- if methods.using_clang(env) and not methods.is_vanilla_clang(env):
-- # Apple Clang, its linker doesn't like -s.
-- env.Append(LINKFLAGS=["-Wl,-S", "-Wl,-x", "-Wl,-dead_strip"])
-- else:
-- env.Append(LINKFLAGS=["-s"])
-
diff --git a/dev-games/godot/godot-3.5.3-r1.ebuild b/dev-games/godot/godot-3.5.3-r1.ebuild
deleted file mode 100644
index 9a41621d39b5..000000000000
--- a/dev-games/godot/godot-3.5.3-r1.ebuild
+++ /dev/null
@@ -1,218 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit desktop python-any-r1 scons-utils shell-completion toolchain-funcs xdg
-
-DESCRIPTION="Multi-platform 2D and 3D game engine with a feature-rich editor"
-HOMEPAGE="https://godotengine.org/"
-SRC_URI="
- https://downloads.tuxfamily.org/godotengine/${PV}/${P}-stable.tar.xz
- https://github.com/godotengine/godot/releases/download/${PV}-stable/${P}-stable.tar.xz
-"
-S="${WORKDIR}/${P}-stable"
-
-LICENSE="
- MIT
- Apache-2.0 BSD Boost-1.0 CC0-1.0 Unlicense ZLIB
- gui? ( CC-BY-4.0 ) tools? ( BitstreamVera OFL-1.1 )
-"
-SLOT="3"
-KEYWORDS="~amd64"
-# Enable roughly same as upstream by default so it works as expected,
-# except raycast (tools-only heavy dependency), and deprecated.
-IUSE="
- +bullet debug deprecated +gui pulseaudio raycast +runner +theora
- +tools +udev +upnp +webm +webp
-"
-
-# dlopen: alsa-lib,pulseaudio,udev
-RDEPEND="
- app-arch/zstd:=
- dev-games/recastnavigation:=
- dev-libs/libpcre2:=[pcre32]
- media-libs/alsa-lib
- media-libs/freetype[brotli]
- media-libs/libpng:=
- <net-libs/mbedtls-3:=
- net-libs/wslay
- sys-libs/zlib:=
- bullet? ( sci-physics/bullet:= )
- gui? (
- media-libs/libglvnd
- x11-libs/libX11
- x11-libs/libXcursor
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libXrandr
- x11-libs/libXrender
- tools? ( raycast? ( media-libs/embree:3 ) )
- )
- pulseaudio? ( media-libs/libpulse )
- theora? (
- media-libs/libogg
- media-libs/libtheora
- media-libs/libvorbis
- )
- tools? ( app-misc/ca-certificates )
- udev? ( virtual/udev )
- webm? (
- media-libs/libvorbis
- media-libs/libvpx:=
- media-libs/opus
- )
- webp? ( media-libs/libwebp:= )
-"
-DEPEND="
- ${RDEPEND}
- gui? ( x11-base/xorg-proto )
-"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.5-musl.patch
- "${FILESDIR}"/${PN}-3.5-scons.patch
- "${FILESDIR}"/${PN}-3.5.3-gcc13.patch
-)
-
-src_prepare() {
- default
-
- # handle slotting
- sed -i "1,5s/ godot/&${SLOT}/i" misc/dist/linux/godot.6 || die
- sed -i "/id/s/Godot/&${SLOT}/" misc/dist/linux/org.godotengine.Godot.appdata.xml || die
- sed -e "s/=godot/&${SLOT}/" -e "/^Name=/s/$/ ${SLOT}/" \
- -i misc/dist/linux/org.godotengine.Godot.desktop || die
- sed -e "s/godot/&${SLOT}/g" \
- -i misc/dist/shell/{godot.bash-completion,godot.fish,_godot.zsh-completion} || die
-
- sed -i "s|pkg-config |$(tc-getPKG_CONFIG) |" platform/{x11,server}/detect.py || die
-
- # use of builtin_ switches can be messy (see below), delete to be sure
- local unbundle=(
- bullet embree freetype libogg libpng libtheora libvorbis libvpx
- libwebp mbedtls opus pcre2 recastnavigation wslay zlib zstd # miniupnpc
- # certs: unused by generated header, but scons panics if not found
- # miniupnpc: check if can re-add on bump, bug #934044
- )
- rm -r "${unbundle[@]/#/thirdparty/}" || die
-}
-
-src_compile() {
- local -x BUILD_NAME=gentoo # replaces "custom_build" in version string
-
- local esconsargs=(
- AR="$(tc-getAR)" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
-
- platform=$(usex gui x11 server)
- progress=no
- verbose=yes
-
- deprecated=$(usex deprecated)
- #execinfo=$(usex !elibc_glibc) # libexecinfo is not packaged
- minizip=yes # uses a modified bundled copy
- pulseaudio=$(usex pulseaudio)
- udev=$(usex udev)
-
- system_certs_path="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
-
- # platform/*/detect.py uses builtin_* switches to check if need
- # to link with system libraries, but ignores whether the dep is
- # actually used, so "enable" deleted builtins on disabled deps
- builtin_bullet=$(usex !bullet)
- builtin_certs=no
- builtin_embree=$(usex !gui yes $(usex !tools yes $(usex !raycast)))
- builtin_enet=yes # bundled copy is patched for IPv6+DTLS support
- builtin_freetype=no
- builtin_libogg=yes # unused
- builtin_libpng=no
- builtin_libtheora=$(usex !theora)
- builtin_libvorbis=$(usex !theora $(usex !webm))
- builtin_libvpx=$(usex !webm)
- builtin_libwebp=$(usex !webp)
- builtin_mbedtls=no
- builtin_miniupnpc=yes #934044 (for now, should revisit)
- builtin_opus=$(usex !webm)
- builtin_pcre2=no
- builtin_recast=no
- builtin_rvo2=yes # bundled copy has godot-specific changes
- builtin_squish=yes # ^ likewise, may not be safe to unbundle
- builtin_wslay=no
- builtin_xatlas=yes # not wired for unbundling nor packaged
- builtin_zlib=no
- builtin_zstd=no
- # (more is bundled in third_party/ but they lack builtin_* switches)
-
- # modules with optional dependencies, "possible" to disable more but
- # gets messy and breaks all sorts of features (expected enabled)
- module_bullet_enabled=$(usex bullet)
- module_mono_enabled=no # unhandled
- module_ogg_enabled=no # unused
- module_opus_enabled=no # unused, support is gone and webm uses system's
- # note raycast is disabled on many arches, see raycast/config.py
- module_raycast_enabled=$(usex gui $(usex tools $(usex raycast)))
- module_theora_enabled=$(usex theora)
- module_upnp_enabled=$(usex upnp)
- module_vorbis_enabled=no # unused, non-theora/webm uses stb_vorbis
- module_webm_enabled=$(usex webm)
- module_webp_enabled=$(usex webp)
-
- # let *FLAGS handle these, e.g. can pass -flto as-is
- debug_symbols=no
- optimize=none
- use_lto=no
- use_static_cpp=no
- )
-
- if use runner && use tools; then
- # build alternate faster + ~60% smaller binary for running
- # games or servers without game development debug paths
- escons extra_suffix=runner target=release tools=no "${esconsargs[@]}"
- fi
-
- esconsargs+=(
- # debug: debug for godot itself
- # release_debug: debug for game development
- # release: no debugging paths, only available with tools=no
- target=$(usex debug{,} $(usex tools release_debug release))
- tools=$(usex tools)
- )
-
- escons extra_suffix=main "${esconsargs[@]}"
-}
-
-src_install() {
- local s=godot${SLOT}
-
- newbin bin/godot*.main ${s}
- if use runner && use tools; then
- newbin bin/godot*.runner ${s}-runner
- else
- # always available, revdeps shouldn't depend on [runner]
- dosym ${s} /usr/bin/${s}-runner
- fi
-
- newman misc/dist/linux/godot.6 ${s}.6
- dodoc AUTHORS.md CHANGELOG.md DONORS.md README.md
-
- if use gui; then
- newicon icon.svg ${s}.svg
- newmenu misc/dist/linux/org.godotengine.Godot.desktop \
- org.godotengine.${s^}.desktop
-
- insinto /usr/share/metainfo
- newins misc/dist/linux/org.godotengine.Godot.appdata.xml \
- org.godotengine.${s^}.appdata.xml
-
- insinto /usr/share/mime/application
- newins misc/dist/linux/org.godotengine.Godot.xml \
- org.godotengine.${s^}.xml
- fi
-
- newbashcomp misc/dist/shell/godot.bash-completion ${s}
- newfishcomp misc/dist/shell/godot.fish ${s}.fish
- newzshcomp misc/dist/shell/_godot.zsh-completion _${s}
-}
diff --git a/dev-games/godot/godot-4.2.2-r1.ebuild b/dev-games/godot/godot-4.2.2-r1.ebuild
deleted file mode 100644
index d9ea297149f2..000000000000
--- a/dev-games/godot/godot-4.2.2-r1.ebuild
+++ /dev/null
@@ -1,238 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit desktop python-any-r1 flag-o-matic scons-utils
-inherit shell-completion toolchain-funcs xdg
-
-DESCRIPTION="Multi-platform 2D and 3D game engine with a feature-rich editor"
-HOMEPAGE="https://godotengine.org/"
-SRC_URI="
- https://downloads.tuxfamily.org/godotengine/${PV}/${P}-stable.tar.xz
- https://github.com/godotengine/godot/releases/download/${PV}-stable/${P}-stable.tar.xz
-"
-S=${WORKDIR}/${P}-stable
-
-LICENSE="
- MIT
- Apache-2.0 BSD Boost-1.0 CC0-1.0 Unlicense ZLIB
- gui? ( CC-BY-4.0 ) tools? ( OFL-1.1 )
-"
-SLOT="4"
-KEYWORDS="~amd64"
-# Enable roughly same as upstream by default so it works as expected,
-# except raycast (tools-only heavy dependency), and deprecated.
-IUSE="
- alsa +dbus debug deprecated +fontconfig +gui pulseaudio raycast
- +runner speech test +theora +tools +udev +upnp +vulkan +webp
-"
-# TODO: tests still need more figuring out
-RESTRICT="test"
-
-# dlopen: libglvnd
-RDEPEND="
- app-arch/brotli:=
- app-arch/zstd:=
- dev-games/recastnavigation:=
- dev-libs/icu:=
- dev-libs/libpcre2:=[pcre32]
- media-libs/freetype[brotli,harfbuzz]
- media-libs/harfbuzz:=[icu]
- media-libs/libogg
- media-libs/libpng:=
- media-libs/libvorbis
- <net-libs/mbedtls-3:=
- net-libs/wslay
- sys-libs/zlib:=
- alsa? ( media-libs/alsa-lib )
- dbus? ( sys-apps/dbus )
- fontconfig? ( media-libs/fontconfig )
- gui? (
- media-libs/libglvnd
- x11-libs/libX11
- x11-libs/libXcursor
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libxkbcommon
- tools? ( raycast? ( media-libs/embree:3 ) )
- vulkan? ( media-libs/vulkan-loader[X] )
- )
- pulseaudio? ( media-libs/libpulse )
- speech? ( app-accessibility/speech-dispatcher )
- theora? ( media-libs/libtheora )
- tools? ( app-misc/ca-certificates )
- udev? ( virtual/udev )
- webp? ( media-libs/libwebp:= )
-"
-DEPEND="
- ${RDEPEND}
- gui? ( x11-base/xorg-proto )
- tools? ( test? ( dev-cpp/doctest ) )
-"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.0_rc2-musl.patch
- "${FILESDIR}"/${PN}-4.0_rc3-scons.patch
-)
-
-src_prepare() {
- default
-
- # handle slotting
- sed -i "1,5s/ godot/&${SLOT}/i" misc/dist/linux/godot.6 || die
- sed -i "/id/s/Godot/&${SLOT}/" misc/dist/linux/org.godotengine.Godot.appdata.xml || die
- sed -e "s/=godot/&${SLOT}/" -e "/^Name=/s/$/ ${SLOT}/" \
- -i misc/dist/linux/org.godotengine.Godot.desktop || die
- sed -e "s/godot/&${SLOT}/g" \
- -i misc/dist/shell/{godot.bash-completion,godot.fish,_godot.zsh-completion} || die
-
- sed -i "s|pkg-config |$(tc-getPKG_CONFIG) |" platform/linuxbsd/detect.py || die
-
- # use of builtin_ switches can be messy (see below), delete to be sure
- local unbundle=(
- brotli doctest embree freetype graphite harfbuzz icu4c libogg
- libpng libtheora libvorbis libwebp linuxbsd_headers mbedtls
- pcre2 recastnavigation volk wslay zlib zstd
- # certs: unused by generated header, but scons panics if not found
- # miniupnpc: check if can re-add on bump, bug #934044
- )
- rm -r "${unbundle[@]/#/thirdparty/}" || die
-
- ln -s "${ESYSROOT}"/usr/include/doctest thirdparty/ || die
-}
-
-src_compile() {
- local -x BUILD_NAME=gentoo # replaces "custom_build" in version string
-
- filter-lto #921017
-
- local esconsargs=(
- AR="$(tc-getAR)" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
-
- progress=no
- verbose=yes
-
- use_sowrap=no
-
- alsa=$(usex alsa)
- dbus=$(usex dbus)
- deprecated=$(usex deprecated)
- fontconfig=$(usex fontconfig)
- opengl3=$(usex gui)
- pulseaudio=$(usex pulseaudio)
- speechd=$(usex speech)
- udev=$(usex udev)
- use_volk=no # unnecessary when linking directly to libvulkan
- vulkan=$(usex gui $(usex vulkan))
- x11=$(usex gui)
-
- system_certs_path="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
-
- # platform/*/detect.py uses builtin_* switches to check if need
- # to link with system libraries, but many ignore whether the dep
- # is actually used, so "enable" deleted builtins on disabled deps
- builtin_brotli=no
- builtin_certs=no
- builtin_clipper2=yes # not packaged
- builtin_embree=$(usex !gui yes $(usex !tools yes $(usex !raycast)))
- builtin_enet=yes # bundled copy is patched for IPv6+DTLS support
- builtin_freetype=no
- builtin_glslang=yes #879111 (for now, may revisit if more stable)
- builtin_graphite=no
- builtin_harfbuzz=no
- builtin_icu4c=no
- builtin_libogg=no
- builtin_libpng=no
- builtin_libtheora=$(usex !theora)
- builtin_libvorbis=no
- builtin_libwebp=$(usex !webp)
- builtin_mbedtls=no
- builtin_miniupnpc=yes #934044 (for now, should revisit)
- builtin_msdfgen=yes # not wired for unbundling nor packaged
- builtin_openxr=yes # not packaged
- builtin_pcre2=no
- builtin_recastnavigation=no
- builtin_rvo2=yes # bundled copy has godot-specific changes
- builtin_squish=yes # ^ likewise, may not be safe to unbundle
- builtin_wslay=no
- builtin_xatlas=yes # not wired for unbundling nor packaged
- builtin_zlib=no
- builtin_zstd=no
- # (more is bundled in third_party/ but they lack builtin_* switches)
-
- # modules with optional dependencies, "possible" to disable more but
- # gets messy and breaks all sorts of features (expected enabled)
- module_mono_enabled=no # unhandled
- # note raycast is only enabled on amd64+arm64, see raycast/config.py
- module_raycast_enabled=$(usex gui $(usex tools $(usex raycast)))
- module_theora_enabled=$(usex theora)
- module_upnp_enabled=$(usex upnp)
- module_webp_enabled=$(usex webp)
-
- # let *FLAGS handle these
- debug_symbols=no
- lto=none
- optimize=custom
- use_static_cpp=no
- )
-
- if use runner && use tools; then
- # build alternate faster + ~60% smaller binary for running
- # games or servers without game development debug paths
- escons extra_suffix=runner target=template_release "${esconsargs[@]}"
- fi
-
- esconsargs+=(
- target=$(usex tools editor template_$(usex debug{,} release))
- dev_build=$(usex debug)
-
- # harmless but note this bakes in --test in the final binary
- tests=$(usex tools $(usex test))
- )
-
- escons extra_suffix=main "${esconsargs[@]}"
-}
-
-src_test() {
- xdg_environment_reset
- bin/godot*.main --headless --test || die
-}
-
-src_install() {
- local s=godot${SLOT}
-
- newbin bin/godot*.main ${s}
- if use runner && use tools; then
- newbin bin/godot*.runner ${s}-runner
- else
- # always available, revdeps shouldn't depend on [runner]
- dosym ${s} /usr/bin/${s}-runner
- fi
-
- newman misc/dist/linux/godot.6 ${s}.6
- dodoc AUTHORS.md CHANGELOG.md DONORS.md README.md
-
- if use gui; then
- newicon icon.svg ${s}.svg
- newmenu misc/dist/linux/org.godotengine.Godot.desktop \
- org.godotengine.${s^}.desktop
-
- insinto /usr/share/metainfo
- newins misc/dist/linux/org.godotengine.Godot.appdata.xml \
- org.godotengine.${s^}.appdata.xml
-
- insinto /usr/share/mime/application
- newins misc/dist/linux/org.godotengine.Godot.xml \
- org.godotengine.${s^}.xml
- fi
-
- newbashcomp misc/dist/shell/godot.bash-completion ${s}
- newfishcomp misc/dist/shell/godot.fish ${s}.fish
- newzshcomp misc/dist/shell/_godot.zsh-completion _${s}
-}
diff --git a/dev-games/godot/metadata.xml b/dev-games/godot/metadata.xml
index 71f596fee4e9..ef5e4ba49472 100644
--- a/dev-games/godot/metadata.xml
+++ b/dev-games/godot/metadata.xml
@@ -20,12 +20,10 @@
and consoles.
</longdescription>
<use>
- <flag name="bullet">Enable the <pkg>sci-physics/bullet</pkg> module</flag>
<flag name="deprecated">Enable support for deprecated features</flag>
<flag name="raycast">Enable the raycast Editor module using <pkg>media-libs/embree</pkg></flag>
<flag name="runner">Build an additional binary optimized for running games (only relevant with USE=tools)</flag>
<flag name="tools">Enable the Godot Editor for game development</flag>
- <flag name="webm">Enable the WebM module</flag>
</use>
<upstream>
<doc>https://docs.godotengine.org/</doc>