summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/xacro/xacro-1.14.1.ebuild')
-rw-r--r--dev-ros/xacro/xacro-1.14.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-ros/xacro/xacro-1.14.1.ebuild b/dev-ros/xacro/xacro-1.14.1.ebuild
index e29730c0f573..70c940ca810a 100644
--- a/dev-ros/xacro/xacro-1.14.1.ebuild
+++ b/dev-ros/xacro/xacro-1.14.1.ebuild
@@ -13,9 +13,12 @@ LICENSE="BSD"
SLOT="0"
IUSE=""
-RDEPEND="dev-ros/roslint[${PYTHON_USEDEP}]"
+RDEPEND="dev-ros/roslint[${PYTHON_SINGLE_USEDEP}]"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )
"
RDEPEND="${RDEPEND}
- dev-ros/roslaunch[${PYTHON_USEDEP}]"
+ dev-ros/roslaunch[${PYTHON_SINGLE_USEDEP}]"