summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/wstool')
-rw-r--r--dev-util/wstool/wstool-0.1.18.ebuild8
-rw-r--r--dev-util/wstool/wstool-9999.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-util/wstool/wstool-0.1.18.ebuild b/dev-util/wstool/wstool-0.1.18.ebuild
index 41972a54bea4..3a75c3bd2270 100644
--- a/dev-util/wstool/wstool-0.1.18.ebuild
+++ b/dev-util/wstool/wstool-0.1.18.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -34,7 +34,6 @@ RDEPEND="
>=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- dev-python/sphinx
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
@@ -44,6 +43,9 @@ DEPEND="${RDEPEND}
dev-vcs/subversion
)
"
+BDEPEND="
+ dev-python/sphinx
+"
DISTUTILS_IN_SOURCE_BUILD="yes"
diff --git a/dev-util/wstool/wstool-9999.ebuild b/dev-util/wstool/wstool-9999.ebuild
index 41972a54bea4..3a75c3bd2270 100644
--- a/dev-util/wstool/wstool-9999.ebuild
+++ b/dev-util/wstool/wstool-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -34,7 +34,6 @@ RDEPEND="
>=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- dev-python/sphinx
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
@@ -44,6 +43,9 @@ DEPEND="${RDEPEND}
dev-vcs/subversion
)
"
+BDEPEND="
+ dev-python/sphinx
+"
DISTUTILS_IN_SOURCE_BUILD="yes"