summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2022-11-15 09:29:28 +0100
committerhaarp <main.haarp@gmail.com>2022-11-15 09:29:28 +0100
commitcf3e072c32b8b8eb6fe0c683fed21f1129ab720f (patch)
tree1fcbcf9d0dad42b2ca52863b0ed25b6be37d62d4
parentdns2tcp: New source (diff)
downloadhaarp-cf3e072c32b8b8eb6fe0c683fed21f1129ab720f.tar.gz
haarp-cf3e072c32b8b8eb6fe0c683fed21f1129ab720f.tar.bz2
haarp-cf3e072c32b8b8eb6fe0c683fed21f1129ab720f.zip
Add Space Cadet Pinball
Signed-off-by: haarp <main.haarp@gmail.com>
-rw-r--r--games-arcade/SpaceCadetPinball/Manifest2
-rw-r--r--games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/games-arcade/SpaceCadetPinball/Manifest b/games-arcade/SpaceCadetPinball/Manifest
new file mode 100644
index 0000000..276feb0
--- /dev/null
+++ b/games-arcade/SpaceCadetPinball/Manifest
@@ -0,0 +1,2 @@
+DIST SpaceCadetPinball-2.0.1.tar.gz 1882629 BLAKE2B 55b2c4232880b065bad30371ad4c170ee2fbc485d2673d25d3afa82144d17bc6a74f70cee7dcc365992df61e95d65a97b57924e54a140b98790ee6e75b06cefd SHA512 b8a23c650a6251838c531a7f1427284199ba859fbdf8715a974404dbef3485503dffa723839f6b41d335e2afc73a85bd0fe0d670ebb7fc1462f089250f1f546f
+EBUILD SpaceCadetPinball-2.0.1.ebuild 924 BLAKE2B fa452395bcb86eb78ee5ef853e0e3f855af5885cf1e219a8f8776e4edfb3d75f588396af3a1c570c30e5f9ed8be2e2398e810e4851fe4d9d0942cadcd72f2567 SHA512 acc7acd55a3d380cd02bef2c91d574bd4424d21305138150191567a18860407e1a6efbf3832175a15f9e2e9e0364be7e780e8cf59b053d97346329d82b50fae5
diff --git a/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild
new file mode 100644
index 0000000..d341b1c
--- /dev/null
+++ b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Decompilation of 3D Pinball for Windows - Space Cadet"
+HOMEPAGE="https://github.com/k4zmu2a/SpaceCadetPinball"
+SRC_URI="https://github.com/k4zmu2a/${PN}/archive/refs/tags/Release_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/libsdl2
+ media-libs/sdl2-mixer[midi]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-Release_${PV}"
+
+src_prepare(){
+ # the paths should be relative
+ sed -i "s|/Platform|Platform|g" CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+pkg_postinst(){
+ ewarn "This game is distributed without the data files."
+ ewarn "To play, copy the original DAT and SOUND files from a Windows or"
+ ewarn 'Full Tilt! installation and place them in $XDG_DATA_HOME/'"${PN}/"
+ ewarn "(usually: ~/.local/share/${PN}/)"
+
+ xdg_pkg_postinst
+}