summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2012-07-16 11:26:34 -0400
committerJustin Riley <justin.t.riley@gmail.com>2012-07-16 11:27:07 -0400
commit19400556d465a2f971aed431f8be09145872197b (patch)
tree5e25ce7029f67dc45c257da58dd31ec4507dd58f
parentfix more distutils deprecation warnings (diff)
downloadjtriley-19400556d465a2f971aed431f8be09145872197b.tar.gz
jtriley-19400556d465a2f971aed431f8be09145872197b.tar.bz2
jtriley-19400556d465a2f971aed431f8be09145872197b.zip
spotify: fix segfault on launch related to libcef
-rw-r--r--media-sound/spotify/spotify-0.8.3.278.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/media-sound/spotify/spotify-0.8.3.278.ebuild b/media-sound/spotify/spotify-0.8.3.278.ebuild
index 714a9e0..93260c4 100644
--- a/media-sound/spotify/spotify-0.8.3.278.ebuild
+++ b/media-sound/spotify/spotify-0.8.3.278.ebuild
@@ -49,7 +49,7 @@ RDEPEND="${DEPEND}
sys-apps/dbus
sys-apps/util-linux
dev-libs/expat
- dev-libs/nspr
+ >=dev-libs/nspr-4.9
gnome-base/gconf:2
x11-libs/gtk+:2
dev-libs/nss
@@ -91,11 +91,18 @@ src_install() {
insinto ${SPOTIFY_HOME}
doins -r usr/share/spotify/*
fperms +x ${SPOTIFY_HOME}/spotify
- dodir /usr/bin
- dosym ../share/spotify/spotify /usr/bin/spotify
dodir /usr/share
dosym ${SPOTIFY_HOME} /usr/share/spotify
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify
+ #! /bin/sh
+ LD_PRELOAD="\${LD_PRELOAD} /usr/share/spotify/libcef.so"
+ export LD_PRELOAD
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
# revdep-rebuild produces a false positive because of symbol versioning
dodir /etc/revdep-rebuild
cat <<-EOF >"${D}"/etc/revdep-rebuild/10${PN}