aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel de Oliveira <menelkir@itroll.org>2010-05-31 09:49:55 -0300
committerDaniel de Oliveira <menelkir@itroll.org>2010-05-31 09:49:55 -0300
commit709c45929ae694cb4062cedd6b38b83b611025e1 (patch)
treed1233515fda830071a4802c49ed6b46bad54b4e8
downloadmenelkir-709c45929ae694cb4062cedd6b38b83b611025e1.tar.gz
menelkir-709c45929ae694cb4062cedd6b38b83b611025e1.tar.bz2
menelkir-709c45929ae694cb4062cedd6b38b83b611025e1.zip
first commit
-rw-r--r--README5
-rw-r--r--app-benchmarks/hardinfo/Changelog8
-rw-r--r--app-benchmarks/hardinfo/Manifest4
-rw-r--r--app-benchmarks/hardinfo/hardinfo-0.5.1.ebuild34
-rw-r--r--app-benchmarks/hardinfo/hardinfo-9999.ebuild41
-rwxr-xr-xprofiles/repo_name1
-rw-r--r--profiles/thirdpartymirrors0
7 files changed, 93 insertions, 0 deletions
diff --git a/README b/README
new file mode 100644
index 0000000..676395d
--- /dev/null
+++ b/README
@@ -0,0 +1,5 @@
+Hi, all
+This is a personal repository for ebuilds.
+
+Later I write something more here.
+
diff --git a/app-benchmarks/hardinfo/Changelog b/app-benchmarks/hardinfo/Changelog
new file mode 100644
index 0000000..7d3910f
--- /dev/null
+++ b/app-benchmarks/hardinfo/Changelog
@@ -0,0 +1,8 @@
+# ChangeLog for app-benchmarks/hardinfo
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+
+*hardinfo-0.5.1.ebuild (31 May 2010)
+
+31 May 2010; Daniel de Oliveira <menelkir@itroll.org> +hardinfo-0.5.1.ebuild,
++hardinfo-9999.ebuild:
+Initial ebuild.
diff --git a/app-benchmarks/hardinfo/Manifest b/app-benchmarks/hardinfo/Manifest
new file mode 100644
index 0000000..7f4aae4
--- /dev/null
+++ b/app-benchmarks/hardinfo/Manifest
@@ -0,0 +1,4 @@
+DIST hardinfo-0.5.1.tar.bz2 246924 RMD160 ef0c91fa8c0c032cf74a96e045e4823f7fe3b81e SHA1 983f0445aa60e02156bc5a5eaedeffb30b8e4d64 SHA256 a0df6c0d7c92a7d20710b8eb551197398a965aaae053782b89a32a160b731b7a
+EBUILD hardinfo-0.5.1.ebuild 650 RMD160 cd685d2140db98cd57dd53dade7ac029d9ba2cce SHA1 d68f814e72759c837fa1a1d735958318904eb019 SHA256 b07aaacd0172990ae455df3677b224b982f484757ccd3c9dd91bf1f26bbf23e4
+EBUILD hardinfo-9999.ebuild 884 RMD160 2a523093a7148bf64b4692b4115b37139affe8bd SHA1 5570cacfde4f0a52458fd6f7b847a3206f057d7e SHA256 a2905c098a40ec67c01ec7016c347d2eecb494ec1fc649fa215d240baead8a96
+MISC Changelog 266 RMD160 4315ed6472c0186e6ff8f7ecb0e688ee6beb4368 SHA1 449eab9cf7c9ea76cb925f4ae6a54ddfef4ed1df SHA256 926afb5cfeaea99a46f6c4ade8a6a308c61739b14f3c288f6137e05b40afde0d
diff --git a/app-benchmarks/hardinfo/hardinfo-0.5.1.ebuild b/app-benchmarks/hardinfo/hardinfo-0.5.1.ebuild
new file mode 100644
index 0000000..3dfcdae
--- /dev/null
+++ b/app-benchmarks/hardinfo/hardinfo-0.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit eutils
+
+DESCRIPTION="HardInfo is a system information and benchmark tool for Linux systems"
+HOMEPAGE="http://hardinfo.berlios.de/"
+SRC_URI="http://download.berlios.de/hardinfo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.6
+>=net-libs/libsoup-2.2.100"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ econf --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/app-benchmarks/hardinfo/hardinfo-9999.ebuild b/app-benchmarks/hardinfo/hardinfo-9999.ebuild
new file mode 100644
index 0000000..3a6b2b0
--- /dev/null
+++ b/app-benchmarks/hardinfo/hardinfo-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git
+
+EGIT_REPO_URI="git://github.com/lpereira/hardinfo.git"
+
+DESCRIPTION="HardInfo can gather information about your system's hardware and operating system, perform benchmarks, and generate printable reports"
+HOMEPAGE="http://hardinfo.berlios.de/HomePage"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0
+ net-libs/libsoup"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}2
+
+# Can't compile with -O, need filter-flags and we don't have time (;
+src_unpack() {
+ subversion_src_unpack
+ cd ${S}
+ mv ${PN}2/* ./
+# sed -i \
+# -e "s|-fPIC -pipe -Wall -g|-fPIC ${CFLAGS}|" \
+# Makefile.in || die "sed"
+}
+
+src_compile() {
+ econf || die "econf"
+ emake || die "emake"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "einstall"
+}
diff --git a/profiles/repo_name b/profiles/repo_name
new file mode 100755
index 0000000..2e4117a
--- /dev/null
+++ b/profiles/repo_name
@@ -0,0 +1 @@
+Menelkir \ No newline at end of file
diff --git a/profiles/thirdpartymirrors b/profiles/thirdpartymirrors
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/profiles/thirdpartymirrors