summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Mavrinac <mavrinac@gmail.com>2012-02-20 19:44:52 -0500
committerAaron Mavrinac <mavrinac@gmail.com>2012-02-20 19:44:52 -0500
commit85cd59b82f6a70f98cb959241d17217c60016263 (patch)
tree3a369853efd90590b661e6d1c9def6cb53a373ec
parentMake docs optional for sci-libs/pcl. (diff)
downloadezod-85cd59b82f6a70f98cb959241d17217c60016263.tar.gz
ezod-85cd59b82f6a70f98cb959241d17217c60016263.tar.bz2
ezod-85cd59b82f6a70f98cb959241d17217c60016263.zip
Apparently qhull dependency is not optional, but 2010.1 from the official tree seems to work.
-rw-r--r--sci-libs/pcl/Manifest4
-rw-r--r--sci-libs/pcl/files/pcl-1.4.0-with.patch11
-rw-r--r--sci-libs/pcl/pcl-1.4.0.ebuild5
3 files changed, 8 insertions, 12 deletions
diff --git a/sci-libs/pcl/Manifest b/sci-libs/pcl/Manifest
index 3b41621..534d8c2 100644
--- a/sci-libs/pcl/Manifest
+++ b/sci-libs/pcl/Manifest
@@ -1,4 +1,4 @@
AUX pcl-1.4.0-vtk.patch 2443 RMD160 26823e6d3b00ea32470d00a33fdea2353662f64b SHA1 b4b76b6953d4e8c93ff3f7574eda9f20c5cdbf7b SHA256 b388627bf89c16b6d5e682314311c4b9ddc4c49b7eb0c4f17d99fbc0b767280d
-AUX pcl-1.4.0-with.patch 865 RMD160 e83ecd3d2aab276a3dcccbdd38ec61bed3dc5310 SHA1 f37d86a7bca5a43a507f7d4fafc29fb1074c6a13 SHA256 77acdee9fecfcfcf33de997124b3d1bafe0005a40f5c4b5041925bd32132a093
+AUX pcl-1.4.0-with.patch 817 RMD160 b896b3965c3c46f824accbdb7656f3736f49bfc8 SHA1 b9528fc4a637020302957abd7a8bd2502fea01ce SHA256 60dee8979a413143f0fc6705279495abb068b2f65bc6b6392e97a57de4966a5b
DIST PCL-1.4.0-Source.tar.bz2 10626702 RMD160 440de4c12c4aba81d2b6197180df85e008eef4d9 SHA1 dc2f89cfafb098c27291549115d39cc6b425d31f SHA256 20d49246773bb54d4b9e133ef3b8b5081c94d1677d823cc0c2d03bcd5bf30a2b
-EBUILD pcl-1.4.0.ebuild 1565 RMD160 8bf7c50514ee2f3d379316c8aad5f93bcce0564b SHA1 1434c9fc5275d043c07c9f3026fe5b6ff8777070 SHA256 608c2e42338e4755c2e41da06f1621a2e5164f08cf67bcc28267bab1ccbdc320
+EBUILD pcl-1.4.0.ebuild 1516 RMD160 f593cb34d9b739a0c8c3e7e303af24c444538a0e SHA1 f3898d8739f4cf1a5d2fc9af5cb86de520b6f338 SHA256 f733da6b3f6e58dc19ca2af5922c1bd2d16c7cd4c7c1c0a843473cb523ea2c6d
diff --git a/sci-libs/pcl/files/pcl-1.4.0-with.patch b/sci-libs/pcl/files/pcl-1.4.0-with.patch
index 357fcd6..f921a67 100644
--- a/sci-libs/pcl/files/pcl-1.4.0-with.patch
+++ b/sci-libs/pcl/files/pcl-1.4.0-with.patch
@@ -1,6 +1,6 @@
--- PCL-1.4.0-Source.old/CMakeLists.txt 2012-01-01 20:39:43.000000000 -0500
-+++ PCL-1.4.0-Source/CMakeLists.txt 2012-02-20 17:21:10.000000000 -0500
-@@ -128,13 +128,19 @@
++++ PCL-1.4.0-Source/CMakeLists.txt 2012-02-20 19:37:03.000000000 -0500
+@@ -128,13 +128,17 @@
# OpenMP
include(${PCL_SOURCE_DIR}/cmake/pcl_openmp.cmake)
# OpenNI
@@ -9,10 +9,7 @@
+ find_package(OpenNI)
+endif()
# Qhull
--find_package(Qhull)
-+if(WITH_QHULL)
-+ find_package(Qhull)
-+endif()
+ find_package(Qhull)
# Find ROS
include(${PCL_SOURCE_DIR}/cmake/pcl_find_ros.cmake)
# Find VTK
@@ -23,7 +20,7 @@
if(VTK_FOUND)
set(VTK_FOUND TRUE)
message(STATUS "VTK found (include: ${VTK_INCLUDE_DIRS}, lib: ${VTK_LIBRARY_DIRS})")
-@@ -142,7 +148,9 @@
+@@ -142,7 +146,9 @@
set(HAVE_VTK ON)
endif()
#Find MPI
diff --git a/sci-libs/pcl/pcl-1.4.0.ebuild b/sci-libs/pcl/pcl-1.4.0.ebuild
index 3556033..8873bf9 100644
--- a/sci-libs/pcl/pcl-1.4.0.ebuild
+++ b/sci-libs/pcl/pcl-1.4.0.ebuild
@@ -15,16 +15,16 @@ SRC_URI="http://dev.pointclouds.org/attachments/download/610/${MY_P}-Source.tar.
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="cuda doc mpi qhull +vtk"
+IUSE="cuda doc mpi +vtk"
RDEPEND="
>=dev-libs/boost-1.46
dev-cpp/eigen:3
>=sci-libs/flann-1.7.1
+ >=media-libs/qhull-2010.1
cuda? ( >=dev-util/nvidia-cuda-toolkit-4 )
doc? ( app-doc/doxygen )
mpi? ( virtual/mpi )
- qhull? ( >=media-libs/qhull-2011.1 )
vtk? ( >=sci-libs/vtk-5.6.0 )
"
DEPEND="${RDEPEND}"
@@ -48,7 +48,6 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with mpi)
- $(cmake-utils_use_with qhull)
$(cmake-utils_use_with vtk)
$(cmake-utils_use_build doc)
$(cmake-utils_use_build test TESTS)